SIM connectivity issues

Major Incident Payment Processing POS (Terminal)
2023-03-16 03:00 GMT · 12 hours, 15 minutes

Update

Resolved

Our network provider has confirmed that they consider all network congestion arising from this incident has been cleared as of approximately 14:00 UTC

Any customers who continue to experience connection issues should contact CabCard support for assistance.

Thank you for your patience and understanding while this technical issue was resolved.

March 16, 2023 · 15:15 GMT
Monitoring

Traffic is now approaching normal levels and most customers should be able to use POS terminals as normal. We will continue to monitor the situation while the remaining network congestion is cleared.

Thank you to all affected customers for your continuing patience.

March 16, 2023 · 13:11 GMT
Monitoring

Traffic levels are steadily increasing as network congestion is actively being reduced by our network provider. We will continue to monitor the situation and provide updates as information becomes available.

March 16, 2023 · 11:05 GMT
Update

Our SIM connectivity provider has confirmed that there was a network issue overnight which has since been resolved. However, this incident resulted in a large amount of network congestion, which is causing some devices to remain unable to connect. This congestion is expected to clear soon and the network engineers are urgently working to improve connection rates.

In the meantime all of CabCard’s systems are working as normal and we urge affected customers to use our alternative payment acceptance channels (payment links and SoftPOS - CabCard Go) to accept payments from cardholders.

We will continue to post information here as it becomes available.

March 16, 2023 · 09:21 GMT
Issue

We have received reports that some customers are unable to connect to the mobile network using CabCard terminals this morning.

We are urgently investigating this issue in conjunction with our network connectivity SIM provider.

Alternative payment acceptance methods are available to all customers including payment links and SoftPOS (CabCard Go). These solutions continue to function as normal.

We apologise for the disruption cased by this issue. Further information will be posted here as it becomes available.

March 16, 2023 · 08:52 GMT

← Back