SIM connectivity issues

Minor Incident Payment Processing POS (Terminal)
2024-02-01 15:16 BST · 2 hours, 31 minutes

Update

Resolved

We observe traffic at normal levels for the past several hours. We consider this incident to be fully resolved.

February 1, 2024 · 17:47 BST
Issue

We are aware that some customers may be experiencing issues with their terminals not connecting to the mobile network.

Our SIM connectivity provider is urgently investigating this issue.

Payment links and SoftPOS payment acceptance continue to work as normal. We recommend that customers should use these alternative payment methods if your POS terminal is unable to connect.

We will post updates to this status page when more information becomes as it becomes available.

February 1, 2024 · 15:16 BST

← Back