Visa and Mastercard POS processing outage

Major Incident Payment Processing POS (Terminal)
2024-05-10 15:51 BST · 1 hour, 26 minutes

Update

Resolved

Payment processing service levels have now returned to normal.

We apologise for the inconvenience caused by this technical disruption, which has now been resolved by our banking partner.

To minimise future disruption, we urge all customers to ensure you are familiar with the alternative payment methods offered by CabCard including Payment Links and CabCard Go (SoftPOS). We also recommend that all customers download and print your CabCard Emergency Kit, which can be found on the Driver Dashboard here.

May 10, 2024 · 17:13 BST
Monitoring

We are beginning to observe service level recovery for this incident.

Transaction processing levels are returning to normal. We are monitoring the situation and will continue to post information on our status page when it becomes available.

May 10, 2024 · 16:35 BST
Update

Our banking partner is aware of the issue and they are working urgently to resolve the technical problem.

Please use the following alternative payment methods to accept payments until this issue is resolved:

  • Payment Links
  • CabCard Go (SoftPOS)

Further information about how to use these payment methods can be found on our support site: support.cabcard.services

May 10, 2024 · 16:25 BST
Issue

We are aware of an issue at one of our banking partners which is preventing Visa and Mastercard POS transactions from being processed when using CabCard terminals.

American Express transactions are being processed as normal.

Customers can use Payment Links and SoftPOS as alternative payment methods.

We recommend customers should log into https://my.cabcard.services and use payment links including the scan to pay feature to accept payments while we work to resolve this incident.

May 10, 2024 · 16:02 BST

← Back