Degraded SIM connectivity levels

Minor Incident Payment Processing POS (Terminal)
2024-07-02 10:42 BST · 6 hours, 40 minutes

Update

Resolved

We continue to observe a good, stable connectivity level for POS terminals and we now consider the incident to be resolved.

We recommend that all customers should review our alternative methods of taking payments, so that you can be prepared for any future technical issues:

July 2, 2024 · 17:20 BST
Monitoring

Our SIM connectivity provider is continuing to work on a resolution for this intermittent network issue.

We have been informed that the underlying issue has been identified and the situation has been stabilised. We believe that most customers should be experiencing a stable network connection now.

We will continue to monitor the situation and post further information to our status page.

July 2, 2024 · 13:46 BST
Issue

We have received reports of degraded connectivity for some POS terminals. A small number of terminals are having difficulty establishing connection to the mobile network.

This has been reported to the relevant partner who provides connectivity services.

If you are affected by this incident, please use alternative payment methods to accept payments from your customers. You can:

We will post updates to our status page when further information is available. Thank you for your patience.

July 2, 2024 · 10:42 BST

← Back