Webhook notification failures

Minor Incident API and Webhooks
2024-07-27 22:15 BST · 3 hours, 34 minutes

Update

Resolved

This issue has now been resolved. All queued webhook notifications have been delivered.

We would like to apologise for any disruption caused by this outage.

We encourage customers to consider how to reduce reliance on receiving real-time webhook notification deliveries to improve the overall robustness of your integrations.

July 28, 2024 · 01:47 BST
Investigating

Our engineers are working with our database hosting provider to resolve the underlying issue causing this incident.

We apologise for the disruption caused by this issue.

We recommend that customers review their integrations to reduce reliance on real-time webhook notifications wherever possible.

Transaction processing is not affected by this incident.

We will post further information here as it becomes available.

July 28, 2024 · 00:15 BST
Issue

Due to database instability, our system is currently experiencing difficulty delivering webhooks. If you have an integration which relies on a webhook integration, it is likely that you may experience delays in receiving webhook notifications.

Transaction processing is not affected and customers can continue to accept payments as normal through all payment channels.

Our engineers are working to resolve the problem, which is caused by a failure at our database hosting provider.

We will post further information on our status page.

July 27, 2024 · 22:44 BST

← Back