Delay to customer payouts

Minor Incident Driver Dashboard Payouts
2024-10-07 16:02 BST · 3 hours, 23 minutes

Update

Resolved

All payouts have been successfully sent to customers. This incident is now considered resolved. Thank you for your patience.

October 7, 2024 · 19:25 BST
Update

The majority of customers have now received today’s payout. There are a small number of remaining payouts which will be completed shortly.

October 7, 2024 · 19:00 BST
Update

All settlement data has now been imported and customer available balances are now displaying accurately. Payouts will be sent shortly according to customer payout schedules.

Thank you for your patience.

October 7, 2024 · 16:51 BST
Issue

Due to a technical issue at one of our banking partners, there is a small delay to customer payouts today. In addition, some customers may notice that their available balance is currently inaccurate due to the late arrival of some settlement data.

Customers will receive payouts as normal this afternoon; we anticipate this may be after 5pm.

Thank you for your patience.

October 7, 2024 · 16:02 BST

← Back