Delayed payout delivery

Minor Incident Payouts
2025-03-10 16:34 · 2 hours, 25 minutes

Update

Times are shown in Africa/Abidjan timezone
Resolved

Payouts have now been completed for all customers. Thank you for your patience.

March 10, 2025 · 18:59
Issue

Due to a delay at one of our banking providers, payouts for some CabCard customers may be delayed this afternoon for a short time beyond the normal payout window (generally payouts are sent between 3pm-5pm).

Payouts will be completed before the end of the working day as normal.

Thanks for your patience.

March 10, 2025 · 16:34

← Back