Delayed processing of payouts
Minor Incident
Payouts
2025-06-10 15:35 BST
· 4 hours, 24 minutes
Update
Resolved
June 10, 2025 · 19:59 BST
All CabCard payouts have been processed for today. Thank you to all affected customers for your patience.
Investigating
June 10, 2025 · 19:26 BST
Payout processing is currently taking place. We apologise for the delay.
We expect that all affected submerchants should receive their payouts before 8pm BST.
Thank you for your patience.
Issue
June 10, 2025 · 15:35 BST
Due to an ongoing incident at an upstream technology provider, we expect that there will be a delay in making payouts for customers today.
We are working to resolve this as soon as possible. We sincerely apologise for the disruption.
We will post information to our status page (https://status.cabcard.services) as it becomes available.
Please do not contact our support team directly, as they cannot provide any additional information beyond this.
← Back