Delayed payout processing

Minor Incident Payouts
2025-06-30 16:37 BST · 2 hours, 23 minutes

Update

Resolved

All payouts have now been processed for today.

This delay was caused by an issue ingesting some data from a third party banking provider. Our engineering team is working to ensure this does not occur again in the future.

Thank you for your patience.

June 30, 2025 · 18:59 BST
Issue

Due to an issue receiving a data file from a third party today, payouts for some customers will be delayed. We do not expect this to be significantly after the normal time.

We apologise for any inconvenience caused by the delay. Information will be provided on our status page.

June 30, 2025 · 16:37 BST

← Back