SMS deliverability degraded service for payment links

Minor Incident API and Webhooks
2025-08-18 12:20 BST · 3 weeks, 4 days, 5 hours, 51 minutes

Update

Update

EE has confirmed that they have removed the spam filter which had been incorrectly applied to the cab.link domain.

This incident is now resolved.

September 24, 2025 · 10:06 BST
Resolved

The workaround we have put in place by using an alternative domain name appears to be successful. Although EE has not yet resolved the issue, we now consider the issue to be resolved as it is no longer impacting customers.

September 12, 2025 · 17:56 BST
Monitoring

Following a period of monitoring, we believe that the workaround we put in place on Sept 10th (changing the short domain used for payment links) has been working successfully, and payment links are being delivered to customers on EE.

We will continue to press EE and our SMS provider for a resolution to this issue and will post updates to this incident as they become available.

September 11, 2025 · 14:44 BST
Update

Despite all efforts, EE has not yet whitelisted the short domain which is used to send payment links by SMS (cab.link). In order to attempt to work around this issue, we have enabled an alternative short domain for this purpose (bill.cab).

No action is needed from impacted customers. We will monitor to determine whether this change has successfully resulted in delivery of SMS to EE mobile numbers.

Again, we apologise to all affected customers for the disruption caused by this issue.

September 10, 2025 · 13:10 BST
Update

We continue working with our suppliers and with EE directly in order to fix the issue of payment link delivery via SMS to EE mobile phone numbers.

The EE carrier network team has acknowledged the issue and has been working on resolving this since August 29th. We continue to push EE for a resolution as quickly as possible.

Meanwhile, we apologise for the inconvenience caused.

September 3, 2025 · 09:35 BST
Update

Our analysis shows that this issue is restricted to SMS messages sent to phone numbers on the EE carrier network.

We are in contact with EE about this, and working to resolve the issue with them. Further information will be posted as it becomes available.

August 28, 2025 · 08:27 BST
Issue

We have observed that a small proportion of SMS text messages being sent by our system to customers for the purpose of payment links (payment requests) are failing to be delivered.

Our analysis indicates that only a small number of SMS attempts are affected (around 3%). It appears that some mobile network carriers are incorrectly filtering the messages and preventing their delivery.

We are working with the relevant third party provider to address this issue as soon as possible, and also identifying options for a workaround in the meantime.

We will post updates to this status page post as further information becomes available.

At this stage we recommend all customers should continue to send payment links by SMS as normal, since most should be received without issues.

August 26, 2025 · 12:36 BST

← Back