Reported SIM connectivity issues

Minor Incident Payment Processing POS (Terminal)
2025-10-15 17:00 BST · 2 weeks, 1 day, 18 hours, 32 minutes

Update

Resolved

We now consider this issue to be resolved. Affected customers can continue to use the supplied instructions to manually select an alternative network to O2.

October 31, 2025 · 10:31 GMT
Update

A small number of customers continue to experience connectivity issues due to the disablement of the O2 3G network. We sincerely apologise for this inconvenience, which is beyond our control.

Please follow the steps below to resolve this issue if your CabCard terminal shows the message “Connecting please wait”:

  1. From the CONNECTING PLEASE WAIT screen, press the UP arrow to display the main menu
  2. Use the arrow keys to select SETTINGS -> CELLULAR NETWORK -> RECONNECTION MODE
  3. Choose MANUAL, then confirm using the green tick button
  4. Select CELLULAR MODE
  5. Select the MANUAL option, then confirm using the green tick button
  6. Switch terminal off and then back on
  7. The screen should display a message in red writing. Press the green tick followed by the UP arrow
  8. Use the arrow keys to select SETTINGS -> SELECT CELLULAR NETWORK -> SELECT NETWORK
  9. The terminal will search for networks. This may take several minutes. When the list appears, select EE or Vodafone.
  10. When “network saved” is displayed, press the red X several times to return to the connecting screen
  11. When the screen shows READY, press the UP arrow to return to SETTINGS
  12. Select CELLULAR NETWORK -> RECONNECTION MODE
  13. Choose AUTOMATIC, then confirm using the green tick button
  14. Select CELLULAR MODE
  15. Choose AUTOMATIC, then confirm using the green tick button
  16. Select CONNECTION TYPE
  17. Choose AUTO, then confirm using the green tick button
  18. When you hear a “beep”, press the red X several times to return to the READY screen
October 20, 2025 · 17:08 BST
Update

We have confirmed that this issue is related to the O2 network and specifically the discontinuation of the 3G network by O2.

If you are experiencing connection issues with your CabCard terminal, please follow these steps to manually select a different network (for example EE or Vodafone):

  1. Press the UP arrow (if you use your terminal in Bluetooth mode, press the yellow arrow and UP arrow together)
  2. Select SETTINGS
  3. Select CELLULAR NETWORK
  4. Select CELLULAR MODE
  5. Select MANUAL
  6. Select SELECT NETWORK
  7. Select a network when the list appears
  8. When you see “successful connection” or network saved”, go back to CELLULAR MODE
  9. Select AUTOMATIC
  10. When you hear a beep keep pressing the red X to take you back to the READY screen
October 16, 2025 · 09:13 BST
Issue

We have received a number of reports from customers indicating that some terminals are experiencing issues establishing a mobile network connection.

We are working urgently with our SIM provider to identify the cause of this issue and will provide further updates here when information becomes available.

All customers can continue to accept payments using CabCard’s alternative payment options: CabCard Go (SoftPOS), Payment Links and Scan to Pay. We encourage all customers to download their emergency kit from the CabCard Driver Dashboard at https://my.cabcard.services

We apologise for any inconvenience caused by this disruption.

October 15, 2025 · 19:17 BST

← Back