Problem processing Visa & Mastercard transactions

Major Incident Payment Processing POS (Terminal)
2020-09-23 09:05 BST · 38 minutes, 16 seconds

Update

Resolved

This issue has now been resolved by the acquirer bank. Transactions are being processed as normal.

Thank you for your patience during this issue. We apologise for any inconvenience caused.

September 23, 2020 · 09:43 BST
Issue

Our acquirer bank is experiencing a technical outage this morning which is preventing Visa and Mastercard transactions from being processed.

They are urgently working to fix this issue and we will post updates here when this is resolved.

We apologise for the inconvenience caused by this outage.

September 23, 2020 · 09:35 BST

← Back