POS terminal SIM connectivity degraded service

Major Incident Payment Processing POS (Terminal)
2025-10-29 16:21 GMT · 1 hour, 42 minutes

Update

Resolved

This incident was resolved at 17:17 GMT. Our monitoring indicates good recovery for traffic levels.

Our provider has confirmed that the underlying issue, which was at Amazon Web Services, has been resolved.

We will request a full Root Cause Analysis and work to ensure future similar incidents are avoided.

We apologise to all customers for the impact of this disruption, and encourage all customers to become familiar with CabCard’s alternative payment methods including the Emergency Kit in order to avoid disruption in future.

October 29, 2025 · 18:02 GMT
Update

Our network connectivity provider has acknowledged the issue and is urgently working to provide a fix.

We sincerely apologise for the disruption.

We encourage all affected customers to use CabCard’s alternative payment methods in order to continue to accept payments.

Updates will be posted to our status page as soon as information becomes available.

October 29, 2025 · 17:10 GMT
Issue

We have become aware of a degraded service level for CabCard customers using POS terminals. Affected customers may not be able to process transactions using CabCard terminals.

We are urgently investigating this and will provide information via our status page as soon as it becomes available.

Affected customers can use CabCard’s alternative payment methods to continue accepting card payments: SoftPOS using the CabCard Android app and Payment Links. Customers can also use the CabCard Emergency Kit which is available from https://my.cabcard.services

October 29, 2025 · 16:21 GMT

← Back