POS network connectivity issue

Major Incident Payment Processing POS (Terminal)
2025-11-18 11:00 GMT · 3 hours, 58 minutes

Update

Resolved

Incident has been resolved.

November 18, 2025 · 14:58 GMT
Investigating

Roaming access to the BT (EE) network was down due to an issue within the BT network, BT have advised that the issue is resolved.

We are observing good recovery for CabCard devices and we now consider this issue to be resolved.

November 18, 2025 · 14:57 GMT
Update

Preliminary investigation suggests this issue may be related to a problem with the BT (EE) network. We recommend that affected customers should try to manually select an alternative network such as Vodafone or O2. Please follow the instructions here to do this: https://support.cabcard.services/terminals/manually-select-a-specific-gprs-network

Customers can also use CabCard’s alternative payment methods to continue accepting payments: Payment Links, SoftPOS and the Emergency Kit

November 18, 2025 · 12:12 GMT
Issue

Since approximately 11am we have received a number of reports from customers indicating that some CabCard terminals are unable to connect to the mobile network and process transactions.

Our network connectivity provider is working urgently to identify and resolve the issue.

At this time we advise customers to use alternative payment processing methods provided by CabCard:

  • Payment Links
  • SoftPOS app for Android (CabCard Go)
  • Emergency Kit (available from my.cabcard.services)

There is a major technical incident ongoing at Cloudflare today which may or may not be related, which is impacting our status page. We will endeavour to post updates and information to the CabCard status page as soon as it becomes available.

Thank you for your patience and please accept our apologies for the disruption.

November 18, 2025 · 12:09 GMT

← Back