SIM connectivity issues

Minor Incident Payment Processing POS (Terminal)
2021-02-26 12:00 BST · 41 minutes, 41 seconds

Update

Resolved

Our network provider has confirmed that a technical issue caused this problem, which has now been rolled back to restore normal operations.

We have confirmed this on our side and believe this incident is now resolved.

Thank you for your patience and apologies for any inconvenience caused by this outage.

February 26, 2021 · 12:41 BST
Issue

We have received reports from customers that some terminals cannot connect to the mobile network. This is displayed on a terminal screen with the message “Connecting, please wait”.

We believe this is caused by a technical issue with the mobile network provider. We are investigating alongside them. Updates will be posted here.

Apologies for any inconvenience caused by this technical fault.

February 26, 2021 · 12:06 BST

← Back