Payout delay

Minor Incident Payment Processing Online (Payment Links) POS (Terminal)
2021-08-27 16:54 GMT · 1 hour, 23 minutes, 4 seconds

Update

Resolved

All payouts have now been completed. Apologies to all customers who were affected by this delay.

August 27, 2021 · 18:17 GMT
Issue

Due to a delay in data processing at one of our banking partners, today’s payouts for have been delayed. We will be processing payouts as normal as soon as possible. Apologies for the inconvenience caused by this delay.

August 27, 2021 · 16:57 GMT

← Back