Duplicated transaction records on dashboards and API

Minor Incident Driver Dashboard Fleet Dashboard API and Webhooks
2022-05-11 15:10 BST · 7 hours, 59 minutes

Update

Resolved

This issue has now been resolved. Data clean up will be carried out over the coming 24 hours, and a full root cause analysis will follow in due course. We apologise for any inconvenience caused by this technical issue.

May 11, 2022 · 23:09 BST
Investigating

The underlying cause of this issue has now been identified and resolved.

We are now working to remove all duplicated transaction records from the system.

Thank you for your patience and apologies for any inconvenience caused by this issue.

May 11, 2022 · 17:20 BST
Issue

We are currently observing a technical issue which has resulted in transaction records being duplicated multiple times for some customers. You may see the same transaction displayed multiple times on your online dashboard or mobile app.

The underlying cardholder transactions have not been duplicated (cardholders will not be charged multiple times). The error is informational only.

For customers with Webhook integrations, you may observe multiple webhook invocations for transactions. API lookups will also observe multiple transactions.

We are working to remediate this and will provide updates here.

Thank you for your patience.

May 11, 2022 · 16:11 BST

← Back