Delayed POS transaction record creation after processing

Major Incident Payment Processing POS (Terminal) Driver Dashboard Fleet Dashboard API and Webhooks
2022-05-30 11:01 BST · 4 hours, 18 minutes

Update

Resolved

After a period of monitoring we continue to observe good levels of system stability and now consider this incident to be resolved.

We apologies for any inconvenience caused. Thank you for your understanding.

May 30, 2022 · 15:19 BST
Monitoring

The underlying issue causing delays between POS transaction processing and sale creation in the database has now been resolved.

All outstanding transactions should now be recorded properly in customer dashboards and also available via the API.

If you are an operator and are using a Webhooks-based integration method (for example via Integromat or Make) we strongly recommend you should review all transactions between 11:00am BST and 14:05 BST today to check that all integration operations (for example, transaction matching) has been carried out correctly, and remediate any errors.

We apologise for any inconvenience caused by this issue.

We will continue to monitor but at the present time the situation has stabilised.

May 30, 2022 · 14:12 BST
Issue

As of approximately 11am BST we have observed some POS transactions are delayed appearing in the customer-facing transaction database.

Transactions are being processed normally and there is no problem with the acceptance of transactions - customers can continue to transact as normal.

However if you are relying on customer dashboards, our API or webhooks integration for confirmation of transactions, please be advised that this issue has caused transactions to appear later than you would expect.

If you are using a webhooks integration, please monitor your integration closely and be advised that some transactions may appear out of order.

We are working on a fix for this issue and will update this incident with further information as soon as possible.

May 30, 2022 · 13:49 BST

← Back