Delayed payouts processing - Mon 8th Aug

Minor Incident Payouts
2022-08-08 15:46 BST · 4 hours, 21 minutes

Update

Resolved

All scheduled payouts have now been completed. Thank you for your patience and understanding.

August 8, 2022 · 20:08 BST
Issue

Due to an upstream technical fault at one of our partner banks, there will be a delay to payouts today (Mon 8th August). All scheduled payouts will be made in due course later today. We apologise for any inconvenience caused by this delay.

August 8, 2022 · 15:48 BST

← Back