Network connectivity issues on Isle of Man

Minor Incident Payment Processing POS (Terminal)
2022-08-12 06:00 GMT · 5 hours, 40 minutes

Update

Resolved

This issue has now been resolved. Thank you to all affected customers for your patience and understanding.

August 12, 2022 · 11:40 GMT
Monitoring

We are observing the affected devices are now able to connect to the IOM network as normal. We will continue to monitor for a period before marking this incident as resolved.

August 12, 2022 · 10:41 GMT
Issue

We are aware that some customers are experiencing issues connecting to the mobile network this morning on the Isle of Man. This is limited to a small subset of affected devices using a particular method of network connectivity. We are working with our network connectivity provider to establish the cause and provide a fix for this issue.

Other payment services (payment links and CabCard Go) are not affected by this issue. Please use alternative methods to accept payments where possible. We will post updates here as information becomes available.

August 12, 2022 · 09:29 GMT

← Back