Terminal connection issue

Major Incident Payment Processing POS (Terminal)
2020-03-06 17:34 BST · 1 hour, 25 minutes, 1 second

Update

Resolved

After continued monitoring we can now confirm that all transactions are proceeding normally and traffic to our servers has returned to expected levels. This issue has now been resolved. Apologies for any inconvenience caused by this technical fault.

November 4, 2021 · 15:24 BST
Issue

We are aware of a technical issue which caused some terminals to experience problems when attempting to make payments starting at 1730 today. We have taken steps to remediate this issue and traffic levels have returned to normal as of 1808. We will continue to monitor this issue and post updates to this status page incident.

November 4, 2021 · 15:24 BST

← Back