American Express intermittent processing errors

Minor Incident Payment Processing POS (Terminal)
2022-08-21 13:00 GMT · 6 hours, 24 minutes

Update

Resolved

The error rate for American Express processing has stabilised and transactions are being processed normally. This issue is now considered to be resolved.

August 21, 2022 · 19:24 GMT
Issue

We have observed an elevated error rate for American Express payment processing. While we work with American Express to resolve this issue, please use an alternative payment method (Visa or Mastercard).

August 21, 2022 · 13:37 GMT

← Back