Back to overview
Downtime

POS connectivity degraded

Apr 17, 2026 at 8:51am UTC
Affected services
POS (payment terminals)

Resolved
Apr 17, 2026 at 10:19am UTC

We continue to observe good levels of network connectivity stability across all customers. This incident is now resolved.

Updated
Apr 17, 2026 at 9:30am UTC

Our SIM provider has investigated this issue, and we are seeing improvement in connectivity for some customers. This issue will be resolved once we are confident that no customers are experiencing the issue.

If your terminal is unable to connect to the mobile network, here are some alternative methods of taking payment with CabCard:

  1. Download and print your emergency kit from my.cabcard.services - the emergency kit has a scannable QR code which you can use to take payments from customers.
  2. Install and set up the CabCard Android app, which allows you to take contactless payments on your phone
  3. Log in to my.cabcard.services and try our payment links and scan-to-pay features

We recommend all customers should take these steps to make sure you're prepared for any future technical issues.

Created
Apr 17, 2026 at 8:51am UTC

We aware aware of reports that some customers are experiencing connectivity issues with their POS terminals as of approximately 09:45am

We are urgently investigating this issue. Updates will be posted here.

Other methods of accepting payments, including through the CabCard SoftPOS app on Android and payments links, are unaffected and can be used normally.