POS SIM connectivity degraded
Resolved
May 19, 2026 at 10:20am UTC
This incident has now been resolved. Thank you for your patience.
We encourage all customers to ensure you have alternative payment methods available in case of future incidents:
- SoftPOS via the CabCard Android app
- Payment links through my.cabcard.services
- CabCard Emergency Kit which can be downloaded and printed from your driver dashboard.
Affected services
Updated
May 19, 2026 at 9:57am UTC
SIM connectivity service has resumed as of 10:49 AM. Customers should be able to connect and process transactions as normal.
We continue to monitor and will post further updates as they become available.
Payment acceptance via other channels (SoftPOS and payment links) is unaffected.
Affected services
Created
May 19, 2026 at 9:31am UTC
We are aware that customers are experiencing degraded SIM connectivity for CabCard POS terminals. We are urgently investigating this in collaboration with our SIM provider. Information will be posted to our status page.
Affected services