Back to overview
Resolved

Transaction processing instability

Jul 13, 2026 at 8:14pm UTC
Affected services
POS (payment terminals)
Webhook Processing

Resolved
Jul 13, 2026 at 8:53pm UTC

A fix has been deployed and all services are online and stable.
Thank you for your patience while we resolved this issue.
Transactions processed during this incident may not display correctly on your dashboard, and your displayed balance may be incorrect. This will not impact settlement of successful transactions.

Updated
Jul 13, 2026 at 8:47pm UTC

We have identified a possible cause for the issue and are testing a fix.

Created
Jul 13, 2026 at 8:14pm UTC

We are currently seeing system instability with our hosting provider. This is impacting transaction processing for some customers.
Our engineers are investigating the root cause and extent of the issue and will update this status page shortly,